Google Play Store obliga a las aplicaciones a adaptarse a Android Pie o superior

Google está obligando a todos los desarrolladores a adaptar sus aplicaciones a Android 9 Pie o superior. La regla se aplicará en Play Store en agosto para las nuevas aplicaciones, y en noviembre para las actualizaciones de las aplicaciones existentes. La empresa también emitirá avisos para APKs distribuidos en tiendas de terceros, como Xiaomi , Huawei y Baidu.

  • Google puede terminar con el botón Atrás en Android Q
  • Google Chrome se integrará al bienestar digital de Android Q

Google Play Store obliga a las aplicaciones a adaptarse a Android Pie o superior 1

La idea es evitar que los desarrolladores se dirijan a versiones anteriores de Android como una forma de eludir las reglas. Por ejemplo, desde Marshmallow 6.0, las aplicaciones han tenido que pedirte permiso antes de acceder al micrófono o a su ubicación. Las aplicaciones de spyware se dirigen a versiones anteriores, como Lollipop 5.0, para no implementar esto.

A partir de ahora, eso será más difícil. A partir de agosto, las nuevas aplicaciones en la Play Store tendrán que dirigirse a Android 9 Pie o superior. Y a partir de noviembre, la regla se extenderá a las actualizaciones.

¿Seguirán siendo compatibles las aplicaciones con versiones anteriores de Android? Sí, por ejemplo, una aplicación puede requerir Lollipop 5.0 como versión mínima , y tener Pie 9.0 como versión de destino . Esto significa que el desarrollador deberá soportar las funciones modernas, como los permisos y los canales de notificación, que estarán activos en los teléfonos inteligentes compatibles.

Vale la pena recordar que, a partir de agosto, Play Store también requerirá que todas las aplicaciones -ya sean nuevas o una actualización- tengan una versión de 64 bits. Todavía se pueden distribuir en 32 bits.

Las tiendas de aplicaciones Xiaomi y Huawei necesitarán soporte Oreo

¿Y fuera de la tienda Play Store? En China, las tiendas Xiaomi, Huawei, Oppo, Vivo, Baidu, Alibaba y Tencentvão requieren que las aplicaciones apunten a Android 8.0 Oreo o superior en 2019.

Además, en agosto, Google Play Protect mostrará una alerta para los usuarios que intenten instalar un APK dirigido a una versión anterior de Android. Por ejemplo, si está en Oreo 8.0, aparecerá una advertencia si la aplicación se dirige a Nougat 7.0 o anterior. A quien ejecute Marshmallow 6.0 se le notificará si la aplicación tiene como objetivo Lollipop 5.0 o anterior, y así sucesivamente.

En noviembre, la misma regla se aplicará a las actualizaciones de APK ya instaladas. A partir de 2020, Google Play Protect necesitará compatibilidad con las versiones más recientes de Android.

Con información: Google.

Contenido relacionado

Deja un comentario